Question

Missing php5-curl package on Ubuntu droplet

Posted August 2, 2014 8.8k views

Hey guys, it seems that my installation is missing the php5-curl package. When I try to run “apt-get intall php5-curl” I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dbconfig-common libmcrypt4 php5-mcrypt
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  php5-curl
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 28.8 kB of archives.
After this operation, 116 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  php5-curl
Install these packages without verification [y/N]? y
Err http://archive.ubuntu.com/ubuntu/ quantal/main php5-curl amd64 5.4.6-1ubuntu1
  404  Not Found [IP: 91.189.92.200 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/php5/php5-curl_5.4.6-1ubuntu1_amd64.deb  404  Not Found [IP: 91.189.92.200 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

And if I run apt-get update it is full of “not found” errors. Any ideas?

2 comments
  • I’m having the same issue.

    When I run sudo apt-get install curl I get:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    curl is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    

    When I run sudo apt-get install php5-curl I get:

    .....
    Install these packages without verification [y/N]? y
    Err http://archive.ubuntu.com/ubuntu/ quantal/main php5-curl amd64 5.4.6-1ubuntu1
      404  Not Found [IP: 91.189.91.13 80]
    Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/php5/php5-curl_5.4.6-1ubuntu1_amd64.deb  404  Not Found [IP: 91.189.91.13 80]
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    

    My Droplet is Ubuntu 12.10 x64 Desktop. And my php version can be seen here: http://theseabreezeinn.com/php-info.php

    I tried “asb"s anwesr below to no avail. I’m at a loss…please help!

  • @leon.amarant: Have you run sudo apt-get update after running the command that @asb posted? It looks like the changes to sources.list haven’t taken effect. Try running that and then installing php5-curl:

    sudo apt-get install php5-curl
    

    Once you’ve done that, I recommend taking a snapshot of your droplet and trying to upgrade to a more recent version of Ubuntu, as 12.10 is no longer supported so you are not receiving both security and regular updates.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

The package php5-curl 5.4.6 doesn’t seem to be part of any supported Ubuntu release:

$ rmadison php5-curl
 php5-curl | 5.3.2-1ubuntu4        | lucid            | amd64, armel, i386, ia64, powerpc, sparc
 php5-curl | 5.3.2-1ubuntu4.26     | lucid-security   | amd64, armel, i386, ia64, powerpc, sparc
 php5-curl | 5.3.2-1ubuntu4.26     | lucid-updates    | amd64, armel, i386, ia64, powerpc, sparc
 php5-curl | 5.3.10-1ubuntu3       | precise          | amd64, armel, armhf, i386, powerpc
 php5-curl | 5.3.10-1ubuntu3.13    | precise-security | amd64, armel, armhf, i386, powerpc
 php5-curl | 5.3.10-1ubuntu3.13    | precise-updates  | amd64, armel, armhf, i386, powerpc
 php5-curl | 5.5.9+dfsg-1ubuntu4   | trusty           | amd64, arm64, armhf, i386, powerpc, ppc64el
 php5-curl | 5.5.9+dfsg-1ubuntu4.3 | trusty-security  | amd64, arm64, armhf, i386, powerpc, ppc64el
 php5-curl | 5.5.9+dfsg-1ubuntu4.3 | trusty-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el
 php5-curl | 5.5.12+dfsg-2ubuntu3  | utopic           | amd64, arm64, armhf, i386, powerpc, ppc64el

I suspect that you must be running an Ubuntu release that has reached “End of Life.” If that’s the case, I’d strongly encourage you to upgrade to a more recent release. If you need to temporarily stay on the outdated release and need to install new packages, you must edit /etc/apt/sources.list and change archive.ubuntu.com to old-releases.ubuntu.com

Here’s a one liner to do that:

sudo sed -i -e 's/archive.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list
Submit an Answer