Question

Modify 'default' apache2 rate-limiting?

Hi all!

I have a webserver where I have bots that ping (via url to a PHP page) the server continuously – Many times per minute.

It seems that after around 3 days some kind of rate limiting / throttling. Which is fixed by a reboot.

I’m not sure how to look for the root cause of this, because I need to be able to let these bots ping the server all they want.

(My server is a “default” UBUNTU server where I followed the tutorial to install LAMP – so I dont believe I have anything “special” enabled).

If it’s not an apache thing, could it be a firewall thing?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Apache has a KeepAlive and KeepAliveTimeout setting that can pose an issue in these instances. If KeepAlive is set to true, then the server will not close a connection after delivering it’s content, rather it will keep it open for additional requests. Turning off the KeepAlive setting in your apache configuration will most likely prevent the server from becoming unreachable after a time as it will then close open connections as soon as it’s work is done, leaving them available to serve new requests.