Question

modprobe tun - ERROR: could not insert 'tun': Unknown symbol in module

  • Posted on November 2, 2014
  • LGAsked by LG

Unable to modprobe tun ERROR: could not insert ‘tun’: Unknown symbol in module, or unknown parameter (see dmesg)

Nov 2 22:55:22 x1 kernel: [102643.488499] Loading kernel module for a network device with CAP_SYS_MODULE (deprecated). Use CAP_NET_ADMIN and alias netdev- instead Nov 2 22:56:48 x1 kernel: [102730.054589] tun: Unknown symbol ipv6_proxy_select_ident (err 0)

ls /lib/modules/uname -r/kernel/drivers/net/tun.*

/lib/modules/3.2.0-4-amd64/kernel/drivers/net/tun.ko

lsb_release -a

No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 7.7 (wheezy) Release: 7.7 Codename: wheezy

uname -a

Linux x1 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I was running into this as well, and I chose “DigitalOcean GrubLoader v0.2 (20160714) Debian” as my kernel (already had sudo apt-get install linux-image-$(uname -r) installed), ran poweroff , and turned instance back on via DO control panel. Now it’s working again!

Worked for me with the last kernel at the moment : Debian 7.0 x64 vmlinuz-3.2.0-4-amd64 (3.2.63-2+deb7u2)

hi,

i tried quite a few different kernels. i am a bit lost about this.

uname -a gives me : 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux

grub (even though it is ignored) seems to point (looking at the menu.lst and the date if the vmlinuz file) this kernel dates from mid january. Debian 7.0 x64 vmlinuz-3.2.0-4-amd64 (3.2.65-1+deb7u1)

i tried to select 3.2.54-2 kernel in droplet options, which by the way is only available in 32bit flavour. or 3.2.65-1+deb7u1. i also tried last debian update Debian 7.0 x64 vmlinuz-3.2.0-4-amd64 (3.2.60-1+deb7u3)

no luck with any of them.

did anyone got this sorted recently ?