orel-s1
By:
orel-s1

ModX won't install on LAMP

June 12, 2013 4.6k views
I've installed LAMP, configured PHPmyAdmin and uploaded ModX CMS files to my droplet (http://modx.com) and tried to install it. First error was with the time zone. But i fixed it in php.ini Then the rest come. It always says, that directory is not writeble... so for a test, I've set ll the directories permissions to 777. But still on the last step, I have an error, that ModX can't unpack a .zip file with it's contents even when permissions on that .zip and all the dircctories are 777. Any ideas, how to fix this? Thanks.
10 Answers
What's the path to the .zip file it's trying to unpack? Also please paste the output of running the stat command on the .zip file and its parent directory.
I have the same issue, here's the output of the stat command:

File: `/var/www/core/packages/core.transport.zip'
Size: 2375026 Blocks: 4640 IO Block: 4096 regular file
Device: fd00h/64768d Inode: 1576448 Links: 1
Access: (0777/-rwxrwxrwx) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2013-07-30 18:23:27.522142075 +0000
Modify: 2013-07-30 16:25:25.322142076 +0000
Change: 2013-07-30 18:23:19.102147512 +0000
Birth: -
What's the output of
stat /var/www/core/packages/
?
File: `/var/www/core/packages/'
Size: 4096 Blocks: 8 IO Block: 4096 directory
Device: fd00h/64768d Inode: 1576446 Links: 16
Access: (0777/drwxrwxrwx) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2013-07-30 18:22:46.310147536 +0000
Modify: 2013-07-30 18:22:29.254148016 +0000
Change: 2013-07-30 18:22:29.254148016 +0000
Birth: -
I recommend asking here so that experienced people can point you to the correct path: http://modx.com/support/
Anybody trying to do an advanced install (moving server) for modx revo I recommend doing a fresh install instead and then uploading any files specific to your installation eg. /assets, /core/components etc
But still it doesn't work properly. Just doesn't want to
@orel-s1: What do you mean by "doesn't work"? Please explain.
i'm using modx too so i hope modx can running well in here
No success for me trying to install the latest 2.2.12 version. Getting the 503 error. First i got it cause of the simple reason that modx requires a empty writable config.inc.php file. So when adding that, the 503 message dissapeared from /, but then trying to run /setup it came back. Thats where i am right now and seem to be a little stuck.

I have added a timezone into the htaccess file as well. Ill be back if i can sort it.
Have another answer? Share your knowledge.