Moved SQL DB to a seperate droplet, now WP says missing mysql extension.

I recently followed the instructions on digital ocean for how to seperate a sql database into a seperate droplet. I am able to connect to the DB server via command line. And everything seems to be correct. Except i removed sql from the web server and now i receive the following message: “Your PHP installation appears to be missing the MySQL extension which is required by WordPress.”

I have even tried to reinstall mysql on the web server and no change. I have rebooted, and tried to think of anything it might be. I can successfully connect to the database using sql client. This droplet was originally a LAMP stack from Digital Ocean and is running Ubuntu.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Try installing php5-mysql