Question

MSMTP via AMS1

  • Posted May 7, 2014

Hi,

On my local machine everything is sent without delay. On ams1 droplet I have a delay in 2-16 secs to send email. And then it’s delivered almost instantly.

Here’s debug output:

host = smtp.yandex.ru port = 587 timeout = off protocol = smtp domain = localhost auth = choose user = bob@domain.com password = * passwordeval = (not set) ntlmdomain = (not set) tls = on tls_starttls = on tls_trust_file = (not set) tls_crl_file = (not set) tls_fingerprint = (not set) tls_key_file = (not set) tls_cert_file = (not set) tls_certcheck = off tls_force_sslv3 = off tls_min_dh_prime_bits = (not set) tls_priorities = (not set) auto_from = off maildomain = (not set) from = bob@domain.com dsn_notify = (not set) dsn_return = (not set) keepbcc = off logfile = (not set) syslog = (not set) aliases = (not set) reading recipients from the command line

then delay (2-16 secs)

<-- 220 smtp4h.mail.yandex.net ESMTP (Want to use Yandex.Mail for your domain? Visit http://pdd.yandex.ru) –> EHLO localhost <-- 250-smtp4h.mail.yandex.net <-- 250-8BITMIME <-- 250-PIPELINING <-- 250-SIZE 42991616 <-- 250-STARTTLS <-- 250-AUTH LOGIN PLAIN <-- 250-DSN <-- 250 ENHANCEDSTATUSCODES –> STARTTLS <-- 220 Go ahead TLS certificate information: Owner: Common Name: smtp.yandex.ru Organization: Yandex LLC Organizational unit: ITO Locality: Moscow State or Province: Russian Federation Country: RU Issuer: Common Name: Certum Level IV CA Organization: Unizeto Technologies S.A. Organizational unit: Certum Certification Authority Country: PL Validity: Activation time: Tue Dec 10 10:22:38 2013 Expiration time: Fri Dec 9 10:22:38 2016 –> EHLO localhost <-- 250-smtp4h.mail.yandex.net <-- 250-8BITMIME <-- 250-PIPELINING <-- 250-SIZE 42991616 <-- 250-AUTH LOGIN PLAIN <-- 250-DSN <-- 250 ENHANCEDSTATUSCODES –> AUTH PLAIN **** <-- 235 2.7.0 Authentication successful. –> MAIL FROM:bob@domain.com –> RCPT TO:test@domain.com –> DATA <-- 250 2.1.0 bob@domain.com ok <-- 250 2.1.5 test@domain.com recipient ok <-- 354 Enter mail, end with “.” on a line by itself –> From: A bob@domain.com –> To: B test@domain.com –> Subject: Hello World –> –> This email was sent using MSMTP via Yandex. –> . <-- 250 2.0.0 Ok: queued on smtp4h.mail.yandex.net as K7lMcNOMQ2-BdH0wg0R –> QUIT <-- 221 2.0.0 Closing connection.

I’ve tried different options in .msmtp_php, but these give min delay. Any suggedtions how can I send emails without delay at all?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You don’t seem to be setting a TLS certificate. If you’re not using it anyways, you might want to set “tls_starttls off”