Question

Multiple Domains, One Linode, Broken Permalinks

Posted December 4, 2017 1.8k views
ApacheServer OptimizationUbuntu 16.04

Hello all! I am attempting to setup two domains on one server, which is working fine for the first domain I set up, however the second domain is having issues with permalinks. I cannot get them setup properly and every thing I have tried in regards to adding Allow Override and Rewrite _____ to the .conf files all wind up redirecting the second domain to the first domain. Is there something wrong with the way I have the .conf files set up? Not sure how to proceed. The article below would have been perfect, if it wasnt deprecated

https://www.digitalocean.com/community/tutorials/how-to-set-up-multiple-wordpress-sites-on-a-single-ubuntu-vps

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

I’m not super familiar with Apache (nginx user), however…! I’ll try to mitigate some common mistakes.

Do you know what kind of redirect you’re getting? As long as your DNS records are correct (A for Ipv4 and AAAA for Ipv6) and not using any redirects on the DNS record then it’s an Apache server or WP settings problem. You should try to nail down if it’s actually Apache or WP that’s doing this as it’s easier to help then.

Also, if you got a permanent redirect, clearing cache is important as the web browser might be remembering your previous settings even if you change them on the server side.

Submit an Answer