Multiple problems with "GitLab One-Click Install Image"

July 13, 2014 1.6k views


I really hoped to get an easy to setup solution with the "GitLab One-Click Install Image", but unfortunately I was disappointed.

After some initial problems, I got it all to work yesterday, but then suddenly today when I tried to add SHH-keys I got an error: 500 from GitLab. A reboot of the server helped the problem, but it still seemed weird and unstable.

Then I tried to create and use a new repo and got the following error on my client side, when I try to push/pull from the repo?:

"Access denied.
fatal: Could not read from remote repository."

I've searched around on the web to find similar problems, but unfortunately my linux skills can quite keep up with the resulting forum-threads - so I am trying here instead in the hope that I am not the only one seeing this at Digital Ocean.

2 Answers


What size droplet are you running it on? GitLab has fairly high memory requirements. We suggest folks use at least the 1 GB droplet. If you're still hitting problems, you might want to add a swap file to the server. Check out this tutorial.

by Justin Ellingwood
Swap space can be used as an "overflow" area for your system when you run out of RAM. The operating system can store data that would normally be kept in RAM on the hard drive in a specially formatted file. In this guide, we'll demonstrate how to create and use one of these files in Ubuntu 14.04.

I also encountered the same problem. My configuration is 1GB RAM and I had already added 2GB swap.

Have another answer? Share your knowledge.