Question

Multiple PTR (reverse DNS) Records (Postfix)

Posted November 3, 2013 36.1k views
Postfix is setup on my droplet where multiple domains (sites) are hosted. When sending some transactional emails from sites, they bounce to certain recipients though. From the mail.log (redacted), "... (host mx.bt.lon5.cpcloud.co.uk[65.20.0.49] refused to talk to me: 521 smtpin48.bt.ext.cpcloud.co.uk Service not available - no PTR record for xxx.xxx.xxx.xxx)" Now, my understanding is that you should only create single PTR records so am a little unsure of how to proceed? I am aware of one option is to use an external service like Mandrill or SendGrid but would like to know what my options are for keeping my emails being sent from my droplet. Thanks!
1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
15 answers
Are there PTR records listed in your DigitalOcean Control Panel?
I have multiple websites running on each droplet though.

If I understand what you are suggesting, while this would solve the issue for one domain the others would still suffer.

Thanks for spending so much time on this though BTW.
You can set the droplet's hostname (which would update the PTR record along with it) to e.g. mail.yourdomain.com where yourdomain.com is one of the domains on that droplet, and then add an A record for mail.yourdomain.com that points to your droplet.

This way it's a valid PTR <=> FQDN setup and it will work fine for all of the domains on that droplet.
Only the ones setup by digital ocean which point to the hostname of the VPS.

e.g.
xxx.xxx.xxx.xxx -> server a
xxx.xxx.xxx.xxx -> server b
and it's the domains that do not form the FQDNs of your droplets that are bouncing?
I don't have any domain names in the PTR record in the DO DNS section. I named my droplets with unique names when creating them.

So yes thats correct but by default really - as none of the domains form the hostnames of my droplets :-).

Log into your DigitalOcean Control Panel and click on Droplets => Settings => Rename for each droplet and rename it -- incorporating your domain name so that you end up w/a FQDN, e.g. hostname.yourdomain.tld
Excellent, thanks very much for your help Kamal and Pablo!
Thanks by the advice.
Just only one question, what about the /etc/hostname file? set it with the same name of the droplets or it isn't necessary?
It should already be set to your droplet's hostname however you can modify it anytime you want and then run
sudo hostname -F /etc/hostname
for the changes to apply.
Previous 1 2 Next