Question

My Apache server won't start. Possible log permissions error.

Hi,

I was on the Apache IRC channel trying to get help because both my vhosts resolve to the same place.

One guy was helping me and he said to output the error logs for the vhosts, which I didn’t have set up, so he told me to do that. I set them up in the vhosts config files, but I couldn’t get the output, so I followed a few forums I found on the net to try to fix the problem.

One thing I did was this: sudo chmod 644 /var/log/apache2/access.log /var/log/apache2/error.log

Then suddenly my server wouldn’t start. So, I changed the vhosts log files back, deleted the folders and changed the permissions back (640) that I had changed above.

Anyway, I still can’t start the server and I am not sure what the problem. My Apache error logs are here http://pastie.org/private/r8lgjkgibabucvlznecq

It says “Unable to open logs, exiting”. I think this is the problem, but I changed the permissions back and it still isn’t working.

Can you give me any direction on how I might fix it?

One note: Another one of the errors says “(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80”

I looked this up and people say to do netstat -tap and kill what is on port 80, but there is nothing on port 80 that I can see.

Thanks.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

A graceful restart fixed it. Hmm… <br> <br>sudo apachectl -k graceful

I should clarify that they don’t say 403. They just say “Forbidden You don’t have permission to access / on this server.” <br> <br>

Thank you. That’s what I did and it worked. Unfortunately, I am getting “Forbidden” 403 errors. <br> <br>Any idea why that might be? <br> <br>Thanks.