Question

My CNAME don't work but why?

I have a free domain (ownhosting.tk). The A Record work perfectly.I add a CNAME for my mail server (mail.ownhosting.tk) but it doesn’t work. i try to open the cmd and type ping mail.ownhosting.tk but it says : “Host Not Found mail.ownhosting.tk etc…” What I can do?

This is my zone file: $ORIGIN ownhosting.tk. $TTL 1800 ownhosting.tk. IN SOA ns1.digitalocean.com. hostmaster.ownhosting.tk. 1440501919 10800 3600 604800 1800 ownhosting.tk. 1800 IN NS ns1.digitalocean.com. ownhosting.tk. 1800 IN NS ns2.digitalocean.com. ownhosting.tk. 1800 IN NS ns3.digitalocean.com. ownhosting.tk. 1800 IN A 104.236.90.56 ownhosting.tk. 1800 IN NS ns4.digitalocean.com. info.ownhosting.tk. 1800 IN CNAME ownhosting.tk. mail.ownhosting.tk. 1800 IN CNAME ownhosting.tk.

Also info.ownhosting.tk doesn’t work.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

If you are trying to setup these records in your DO domain manager, you first need to set the nameservers to digitalocean. Currently you haven’t got this:

#1	ns03.freenom.com	ownhosting.tk	NS	IN	300 (5 min)
#2	ns02.freenom.com	ownhosting.tk	NS	IN	300 (5 min)
#3	ns01.freenom.com	ownhosting.tk	NS	IN	300 (5 min)
#4	ns04.freenom.com	ownhosting.tk	NS	IN	300 (5 min)

If you done this, wait atleast 24 hours before you are trying to get things working threw digitalocean.

You have to change the nameservers at the .tk domain host. They need to point to ns1/ns2/ns3.digitalocean.com. This will tell the domain to look at DO’s nameservers which is where your records are.

Sorry for the question but how do I do this? Could you tell me step by step how do I fix? Thanks anyway