Question

My domain will not resolve, been over a week

  • Posted April 27, 2020
  • DNS

No matter what I do my domain will not resolve for me, and it’s been over a week, so I know for sure this isn’t a propagation issue. The domain is turbolegal.com, and nameservers have been set to the DO nameservers at the registrar, then I’ve added the appropriate A records in DO’s domain management interface.

Checking it here (https://www.digitalocean.com/community/tools/dns?domain=turbolegal.com) everything matches DO, and when I check individual A records, for example, they all show the correct IP address. I’m also able to log into WHM/cPanel no problem by visiting :2087, but just visiting turbolegal.com in a browser it never resolves.

I’ve used this exact same setup for 5 or so Do droplets using cPanel, with domains from various registrars, and have had no issues before. Any ideas?

Thanks in advance!!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

The address is resolving as you say (ping tools, FTP, WHM/cPanel, etc) but the browser connection to the site is timing out. This in not a resolution issue. It looks to be the server is not answering the call for turbolegal.com. Perhaps a typo somewhere in cpanel?

Hi @paulJellyfish,

Pinging your domain at the moment returns an IP related to DigitalOcean so I would assume you found the problem. Can you share what was it?

As for my guess, I’ll say that most probably, you needed to verify the domain or there was a type somewhere in the nameservers. Is that correct?

Looking forward to hearing from you!

Regards, KDSys