Question

My emails are going to Gmail Spam. Droplet created Using LAMP on Ubuntu 14.04 Application. Postfix email.

  • Posted June 17, 2014

Hey,

I created a droplet using the LAMP on Ubuntu 14.04 Application. And apt-get installed postfix and mailutil. Any time I send an email to Gmail it goes to the spam folder.

My Zone file is as follows: <pre> $TTL 1800 @ IN SOA NS1.DIGITALOCEAN.COM. hostmaster.iio.io. ( 1402857717 ; last update: 2014-06-15 18:41:57 UTC 3600 ; refresh 900 ; retry 1209600 ; expire 1800 ; ttl ) IN NS NS1.DIGITALOCEAN.COM. NS NS2.DIGITALOCEAN.COM. NS NS3.DIGITALOCEAN.COM. MX 10 iio.io. *.api CNAME api.iio.io. *.www CNAME www.iio.io. @ IN A 188.226.244.148 www IN A 188.226.244.148 api IN A 188.226.244.148 @ TXT “v=spf1 ip4:188.226.244.148 ~all” mail IN A 188.226.244.148 *.mail CNAME mail.iio.io. </pre>

And the received email is as follows: <pre> Delivered-To: niall1402@gmail.com Received: by 10.220.15.7 with SMTP id i7csp184731vca; Tue, 17 Jun 2014 02:28:48 -0700 (PDT) X-Received: by 10.195.13.79 with SMTP id ew15mr35734652wjd.19.1402997327993; Tue, 17 Jun 2014 02:28:47 -0700 (PDT) Return-Path: niall@iio.io Received: from mail.iio.io (mail.iio.io. [188.226.244.148]) by mx.google.com with ESMTP id b2si11777622wik.18.2014.06.17.02.28.47 for niall1402@gmail.com; Tue, 17 Jun 2014 02:28:47 -0700 (PDT) Received-SPF: pass (google.com: domain of niall@iio.io designates 188.226.244.148 as permitted sender) client-ip=188.226.244.148; Authentication-Results: mx.google.com; spf=pass (google.com: domain of niall@iio.io designates 188.226.244.148 as permitted sender) smtp.mail=niall@iio.io Received: by mail.iio.io (Postfix, from userid 1000) id EB8C9201AF; Tue, 17 Jun 2014 05:28:46 -0400 (EDT) Subject: morn test 2 To: niall1402@gmail.com X-Mailer: mail (GNU Mailutils 2.99.98) Message-Id: 20140617092846.EB8C9201AF@mail.iio.io Date: Tue, 17 Jun 2014 05:28:46 -0400 (EDT) From: niall@iio.io

test morn 2

</pre>

I’ve tried editing the SPF1 record and MX record. I’ve renamed the droplet to mail.iio.io. I’m not sure why it’s still failing and what I can try next?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

My mistake - DKIM is set by Google.

I added opendkim but it didn’t make a difference. Emails are still flagged as spam.

I signed up to Zoho and it works which is great. But I’d still like to figure out how to get emails working without having to use a third party.

Thanks jt,

I doubt that will make a difference as it’s not set when mail is sent from Gmail but I’ll give it a try.

Setup DKIM. It will help authenticate your emails but still isn’t a guarantee that Google will mark them as spam.

Email is a hair pulling game and a lot of people decide to use third party options like Google Apps, Outlook.com, or Mailstache.io.