My ip returns the ghost blog but my domain is returning "Please log into your droplet via SSH to configure your Ghost installation"?

November 7, 2017 1.4k views
Ghost Ubuntu 16.04
5 Answers
by Melissa Anderson
DigitalOcean Droplets are managed using a terminal and SSH. SSH is an encrypted network protocol for remote server login and command execution. It is the standard method used for accessing and interacting with Linux servers. This tutorial shows how to connect to a DigitalOcean Droplet for the first time by using the OpenSSH client.

Yes, the problem was I had to manually setup the domain config on nginx.

@ralphbolo what did you have to put in your domain config file for this to work? I am having the exact same issue and can't figure out what I am doing wrong in my config file. Thanks

  • i had to update the server_name variable and then ssh into it. Not sure which one actually fixed it. Try both.

    server_name mydomain.com

I tried that. I just ended up deleting my droplet, creating an Ubuntu one and manually installing Ghost. A few more steps, but it worked the first time through and is quite honestly, easier that using the DO one click app. I tried that multiple times and always had configuration issues with Nginx.

I just had this same problem. I created the droplet using DO's 'One-Click apps' with Ghost 1.2.11 on Ubuntu 16.04. By default, Ghost installs using the IP address as the domain name. If you try and simply point your DNS to your droplet and then go to your domain, you'll get the blue screen with the shark and "Please log into your droplet via SSH to configure your Ghost installation".

Here's how I fixed it -

First of all, I enabled backups on my droplet. I highly recommend it. It's cheap, and it's worth it x100. When I got to this screen, I started tinkering and got to the point where I wanted to go the route of @paulcimino and just start over. But I figured I would give it a shot first. So I restored my droplet to my earliest backup and removed the DNS for my domain.

Then, I SSH'd into the droplet as root and ran

vim /etc/nginx/sites-available IP_ADDRESS.conf

Change server_name IP_ADDRESS to server_name domain.com

Then run

vim /var/www/ghost/system/files IP_ADDRESS.conf

Change server_name IP_ADDRESS to server_name domain.com

Then run

service nginx restart
  • Apparently, that wasn't at all what I had to do, but it worked. But not completely. When I logged into the Ghost admin panel, I saw my default URL was still set to my IP address. I fixed it by following the answer in this thread here - https://www.digitalocean.com/community/questions/ip-adress-instead-of-domain-name-in-ghost

    SSH into your droplet and run

    vim /var/www/ghost/config.production.json
    

    And edit the URL

    Alternatively, you can login as ghost-mgr and use the Ghost CLI

    sudo -i -u ghost-mgr
    cd /var/www/ghost/
    ghost config url http://example.com
    
Have another answer? Share your knowledge.