Question

My new droplet in SF03/CentOS7 doesn't recognize that do-agent was updated

A few days ago, I created a new droplet and then upgrade do-agent, but the control panel still lists “New! Upgrade your Droplet for additional metrics and alerting.”, and it show me old metrics.

Today I tried again, uninstalling and re-installing the agent, but even a couple hours later I still am not getting the updated metrics (the old ones continue to work though)

My version appears to be up to date, but the control panel won’t recognize it.

Yesterday: I created a support ticket, but I still not getting response.

[root@aws ~]# /opt/digitalocean/bin/do-agent --version

do-agent (DigitalOcean Agent)

Version:     3.5.6
Revision:    7dadc14
Build Date:  Mon Aug 12 14:45:50 UTC 2019
Go Version:  go1.12.1
Website:     https://github.com/digitalocean/do-agent

Copyright (c) 2020 DigitalOcean, Inc. All rights reserved.

This work is licensed under the terms of the Apache 2.0 license.
For a copy, see <https://www.apache.org/licenses/LICENSE-2.0.html>.
[root@aws ~]#
Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Problem solved. Today all the new metrics work properly and I haven’t done anything.