Question

My postfix+dovecot setup is not offering LOGIN auth mechanism. Thus outlook desktop clients cannot connect to my server's SMTP port.

I have a simple postfix with dovecot config that needs to support four or five domains with less than ten users in total. Everything is working for me, as my desktop is Mac. However I have realized that a partner of mine is unable to sent mail from my server, as he is using Outlook and Outlook needs LOGIN mechanism offered in ESMTP. There is no problem related to receiving mail from IMAP ports of Dovecot, but SMTP does not offer LOGIN… I found out that I need to set “auth_mechanisms = plain login”, I did so and now dovecot -n shows auth_mechanism as intended, but still there is no LOGIN mechanism on offer. Help please and thanks in advance.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have the same problem !! It’s because the /etc/dovecot/dovecot.conf dont have the include to read the conf.d files. Put the “auth_mechanisms = plain login” in /etc/dovecot/dovecot.conf