My root password isn't being sent to my Email

January 5, 2019 447 views
Email Ubuntu 16.04

Whenever I make a new droplet, my email doesn’t receive a root password. I’ve tried making new droplets, resetting passwords and even going to the point of deleting all of my emails and trying again. I’ve checked my Spam and other categories, and they still aren’t there. Any help please?

1 comment
  • I am having the same issue. It worked this morning but had to destroy and create new droplet. So far no root password has been sent.

2 Answers

Hi friends, the community won’t be able to help much with this kind of support issue. However, you can follow incidents like this one on the status page: https://status.digitalocean.com/

If events aren’t processing properly generally we recommend you contact support directly.

Whenever I face issue I always contact the service provider. if you are having any issue with your email id or password resetting then you can contact Gmail support number at +1(833)-222-2937 from here you might get some help.

Have another answer? Share your knowledge.