Question

My Server is down with error: file '/boot/grub/i386-pc/normal.mod' not found.

Posted August 12, 2018 4.2k views
DigitalOceanUbuntu 16.04Microservices

When I try to launch the console from panel I get this error: file ‘boot/grub/i386-pc/normal.mod’ not found. And prompt of “grub rescue” comes. I have no idea how to resolve this issue. Here is what I have tried so far:

  1. Tried contacting support but no satisfactory answer. they gave me 2 link as below, I tried and couldn’t find anything.
    https://unix.stackexchange.com/questions/70538/grub-error-file-grub-i386-pc-normal-mod-not-found
    https://askubuntu.com/questions/266429/error-file-grub-i386-pc-normal-mod-not-found

  2. The above links suggested to change the prefix I tried, but it didn’t worked, here is the output of ls.
    grub rescue> ls (hd0,gpt1)/boot
    ./ ../ efi/
    grub rescue> ls (hd0,gpt1)/boot/efi
    ./ ../
    NO FILES/FOLDER inside efi folder and there no grub folder as well. So I think grub is removed. And I have no idea why/how.

SOME INFO ON WHY & HOW PROBLEM STARTED:

  1. I was having issues in accessing the SSH and SFTP it was giving the access denied error. I contacted support and they suggested to do a root password reset from DO panel. I did. And that was the disastrous step. After that server RAM usage is at 60%+ and I am not able to access anything. I tried the root password reset again. Password changed server restarted and we are back to zero.
  2. I tried turning off the server and turn back on. Again no change.

Please help me out. Everything is down.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

What operating system do you have?

The first thing that you should do when setting up a droplet, is create a regular user, give that user ssh permission, and then after testing it, disable root ssh. Then always log in as regular user, then you can su - to root.

Wayne Sallee
Wayne@WayneSallee.com

Submit an Answer