My site is getting offline

December 31, 2017 793 views
Apache DigitalOcean WordPress Ubuntu

since yesterday I have noticed this problem on my website.

Every time I try to access my website, todoatual.com, I have to make several attempts until I can access, but soon after the server falls again.

This happens both in the administrative area and also in the posts.

I do not know how to solve it, can anyone help me?

2 Answers

The first thing you'll want to do is to check your log files. For Apache these can be found in /var/log/apache2 If an error is occurring it will be recorded here. Please share what you find so we can assist in troubleshooting the problem.

I already figured out the problem.

My site has some end-of-the-year and christmas articles, and with that I got a lot of hits.

The site crashes because the ssl that is in it that is from letsencrypt has a limit of accesses that if I am not mistaken is 20 per second, I believe that as the visits spent much of this value ssl simply locked and did not open the blog.

In short, I'll have to hire a more powerful ssl.

  • First handshake of TSL/SSL takes quite amount of resources, so it could be the reason.
    But it has nothing to do with Let's Encrypt. Overall rate limit of 20/sec is for getting new cert/auth/registration, afaik.

    • my site still keeps catching during the day when it has more simltaneous accesses, whenever it does not load, I notice a small bar at the bottom of the browser informing that it is '' establishing secure connection ''

      Do you have any tips on what might be causing this fall?

Have another answer? Share your knowledge.