Question

My website is down even though my droplet says "active"

Hello,

So although in the control panel my droplet is listed as “active”, my website is still down.

I tried running some tests in the command module. When I try to use “curl -l” or “telnet” to see if my server is running, I get the error “connection refused”. After this, I tried to reboot my server. This solved the problem yesterday and I was able to connect to curl -l and telnet, however, upon trying it again today, I am once again getting the response “connection refused” even after the reboot. I am not running nginx or apache2. We use Mongodb and Ubuntu. Memory is not an issue as we are only using about 10% of our available memory. Does anyone else know why my server could be down or how to fix it?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

How do run the application? You can try:

BIND_IP=0.0.0.0 meteor

then visit your_droplet_ip:3000. In any case you can check what ip:port are listening to connections with:

netstat -plnt