Question

My website issues a SQLSTATE[HY000] [1049] Unknown database 'xxxxxx' even after I have imported the database.

I am new to digital ocean, but have recently uploaded a website using the LAMP stack. The website is working fine, however I have an html form on a page that sends the data to a MySQL database. I imported the the database following this tutorial “How to Import and Export Databases in MySQL or MariaDB (https://www.digitalocean.com/community/tutorials/how-to-import-and-export-databases-in-mysql-or-mariadb)”.

When I check for the database in the MySQL interface in terminal through “SHOW DATABASES;”, I see that the database has been imported. I checked phpmyadmin and see that the tables have all been correctly configured. The error still occurs and it seems like my website/droplet is still unknown issuing the SQLSTATE[HY000] [1049] Unknown database ‘xxxxxx’ error.

I use a PHP connection via PDO if that helps.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Are you certain the database mentioned in the error line ‘xxxxxx’ exists? Meaning make sure this DB (‘xxxxxx’) isn’t the name of the old DB on the old server. If that’s the case, try logging in to the DB from the command line using the ‘mysql’ binary like this:

mysql -u db_user -p db_name

Cheers