Question

my wordpress site goes very slow

Hello everyone:

For a couple of weeks ago my website in wordpress going very slow, I have a droplet with 1GB of ram with CentOS, do not know why this is happening. I have only one website hosting up to 12 parallel views, is the only one.

Since I started the site content not increased much, but before I loaded the site in 2 seconds, now I visit each page takes me 30 seconds.

Can anyone help or has any idea what’s going on.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi !
I have a tips for all the people how have slow wordpress, install VARNISH !!! :) this is the how to UBUNTU server:

THAT’S IT ! It work really well and now your website open in 1-2 sec
VARNISH IS AMAZING !!! :D no need to use a non working good CACHE plugins ;)

Nickthevoice

The three files that are taking up to 20 seconds to load are the following:

/wp-content/themes/salient/css/responsive.css.php
/wp-content/themes/salient/css/colors.css.php
/wp-content/themes/salient/css/custom.css.php

Where did you get this theme and why is it generating CSS using PHP? Did the site load time increase after switching to this theme?

If you understand PHP code open these files and check if they’re making HTTP requests to any remote URLs.

You also need to enable gzip compression and set expires header. But they don’t provide a significant boost as of now with these files taking a lot of time: I believe you’re using Nginx so edit the virtual host file of the domain and add the following inside the server {...} block.

	gzip on;
	gzip_disable "msie6";

	gzip_vary on;
	gzip_proxied any;
	gzip_comp_level 6;
	gzip_buffers 16 8k;
	gzip_http_version 1.1;
	gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

	location ~* .(ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|css|rss|atom|js|jpg|jpeg|gif|png|ico|zip|tgz|gz|rar|bz2|doc|xls|exe|ppt|tar|mid|midi|wav|bmp|rtf)$ {
               expires max; log_not_found off; access_log off;
	}