mysql 5.6 Ubuntu 14.04 - unable to start service

August 29, 2015 11k views
MySQL

Hi,

I'm trying to get mysql 5.6 on a Ubuntu 14.04. I did start from scratch with a new droplet, apt-get update, apt-get upgrade. Then doing:

apt-get install mysql-server-5.6

I got:

2015-08-29 08:47:16 0 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
2015-08-29 08:47:16 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.6 (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for ureadahead (0.100.0-16) ...
E: Sub-process /usr/bin/dpkg returned an error code (1)

Trying to start the service manually end-up with:

root@mydroplet:/var/log# service mysql start
start: Job failed to start

Nothing in syslog, nothing in the mysql log. Did try with a apt-get purge but got the same result.

Any idea?

Thanks!

5 comments
  • I am having the same problem with Mysql 5.5 and nothing in the logs

  • This seems to be caused by MySQL ensuring that it's got enough memory before starting the daemon.

    You'll need to either:

    • Provision more RAM to your droplet, or
    • Lower MySQL's configured max_connections

    See the accepted answer on http://askubuntu.com/questions/457923/why-did-installation-of-mysql-5-6-on-ubuntu-14-04-fail for more info.

  • Looks, like there is not enough memory for InnoDB stuff.

    Shortly: add (or replace existing line) to the /etc/mysql/my.cnf :

    innodb_buffer_pool_size = 20M
    

    This will decrease mysql requirements.


    And here is the original answer (with explanations):

    http://stackoverflow.com/a/12683951/1115187

    Another approaches to solve the problem:

    http://askubuntu.com/a/457932/400409

  • Thanks kerasal,

    I had the same problem, I have solved by increasing the size of the memory.

  • Hellow,
    please solve the problem.ican't do it.I can't go my root.

    2015-08-29 08:47:16 0 [Warning] Using unique option prefix keybuffer instead of keybuffersize is deprecated and will be removed in a future release. Please use the full name instead.
    2015-08-29 08:47:16 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit
    defaultsfortimestamp server option (see documentation for more details).
    2017-02-01 21:12:37 0 [Note] mysqld (mysqld 5.6,33-0ubuntu0.14.04.1)starting as process 11230...

2 Answers

Hi,

You should check /var/log/mysql/error.log and /var/log/syslog for more specific errors happening when you try to start MySQL.

Have another answer? Share your knowledge.