hdiario
By:
hdiario

mysql installation error: dpkg: error processing package mysql-server-5.5 (--configure):

July 15, 2015 37k views
DigitalOcean MySQL Ruby on Rails

Hello,
when I run

sudo apt-get update
sudo apt-get install mysql-server mysql-client libmysqlclient-dev

a password input screen comes up. Regardless I choose a password or not, I get following error.

start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
  Package mysql-server-5.5 is not configured yet.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                  Errors were encountered while processing:
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

I even tried

sudo apt-get dist-upgrade

but it only broke postgresql and I had to purge it.
What is the problem and what should I do to install mysql?

1 comment
  • I have purged mysql completely multiple times and I have tried what @CrypticDesigns suggested and I am still getting the below error when I run sudo apt-get install mysql-server.

    dpkg: dependency problems prevent configuration of mysql-server:
     mysql-server depends on mysql-server-5.7; however:
      Package mysql-server-5.7 is not configured yet.
    
    dpkg: error processing package mysql-server (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                              Processing triggers for libc-bin (2.23-0ubuntu5) ...
    Processing triggers for systemd (229-4ubuntu16) ...
    Processing triggers for ureadahead (0.100.0-19) ...
    Errors were encountered while processing:
     mysql-server-5.7
     mysql-server
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
8 Answers

I am not sure if it will work, but try this. First you need to uninstall anything that is related to mysql:

sudo apt-get purge mysql*
sudo apt-get autoremove
sudo apt-get autoclean

Then the important bit, this error could be caused because your distribution is not upgraded recently, or at least conflicts are not resolved properly. So next thing is to upgrade it like you did before but without removing first:

sudo apt-get dist-upgrade

Now after this is done, you can try to install mysql as normal again. Hope this will work, please give a report. If it doesnt work we'll try another fix.

Thank you CrypticDesigns. I went through purging, removing, and cleaning multiple times before and after dist-upgrade. It didn't work for me. Any other suggestion/ solution will be appreciated..

I had similar problem.
Ubuntu 14.04 with preinstalled nginx + mysql 5.5. In July 2015 after one of security updates mysql doesn't finish to install. I've tried shuting down mysql-server before updating without success in updating. Today I've tried to removing and installing again mysql-server but still the same error. Then I stopped and started mysql manually in other shell during updating in aptitude, and problem disapers (ie. on aptitude I have no error message "packages partially installed: mysql-server and mysql-server-5.5")
I hope this will help someone.

Have the same problem as well and I also keep getting unable to set root password.

Ping! Same issue with my server

I get the same error. . No luck with above mentioned solutions :-(

dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.7; however:
Package mysql-server-5.7 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Processing triggers for systemd (229-4ubuntu16) ...
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
mysql-server-5.7
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Have another answer? Share your knowledge.