Question

MySQL server won't start

Posted September 4, 2013 4.6k views
Yo, Today after about 3 weeks of not opening up the CLI I tried to add a new MySQL database. When the command failed to run repeatedly, I then tried to restart the MySQL service. When it was starting it, it came up as failed. I've tried reinstalling MariaDB, I've checked the logs, they had nothing in them, and I've rebooted the droplet a few times. No go. Says it can't connect to the socket, and it's not a permissions issue as far as I can tell. It's really weird because before today I hadn't touched anything for about 3 weeks, and my sites that use MySQL were working fine. Any ideas why this is happening? I appreciate any help.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers
When was the last time you ran sudo apt-get update? Perhaps some of your software packages need updates.
That's one of the things I did before I reinstalled MariaDB.
It can't connect to the socket because there is nothing listening on the socket.

Check MariaDB's error logs, it's failing to start.
Traced it to a bad my.cnf file, which worked fine 3 weeks ago. Oh well.
Submit an Answer