Question

MySQL takes up 100% cpu, tried everything I could find via google

MySQL takes 100% cpu and I don’t know how to fix it.

I disabled replication: SHOW SLAVE STATUS shows 0 rows

SHOW FULL PROCESSLIST doesn’t show any queries taking long time.

I also tried to fix leap second, reboot server, nothing helped.

I don’t know how to further diagnose

When I run top command, it shows mysql process taking 355%-400% CPU (I resized to 4 cores droplet) 1010 mysql 20 0 2414596 184832 13632 S 355.6 2.3 33:13.13 mysqld

Any help is much appreciated!

Subscribe
Share

I have found Server status page in MySQL workbench which gives great mysql core visualisation. I found that my InnoDB Buffer is full there so I increased it and it helped. Thank you.

I tried to diagnose if someone isn’t trying to connect by enabling warning logs before, but found out it’s not an option.

@superbodet as I wrote in my comment above, increasing innodbbuffersize helped. I changed to like 6GB or so

HI @simPod please, how did you solve the problem ? because I have the same issue

Are you seeing anything in your MySQL logs, or in your server’s error or access logs that is out of the ordinary, or is an error?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This question was answered by @simPod:

@superbodet as I wrote in my comment above, increasing innodbbuffersize helped. I changed to like 6GB or so

View the original comment

This comment has been deleted