Question

MySQL to PGLoader migration error on Managed database

I’m trying to migrate to a managed database, both hosted in DigitalOcean, one is a MySQL cluster, the other is a POSTGRES one.

When I enter this command:

pgloader mysql://<DB_USER>:<DB_PASS>@<DB_HOST>:<DB_PORT>/<DB_NAME "postgresql://<DB_USER>:<DB_PASS>@<DB_HOST>:<DB_PORT>/<DB_NAME>"

I get this error:

Failed to connect to pgsql at "MY-HOST" (port MY-PORT) as user "MY-USER": Database error 28000: no pg_hba.conf entry for host <MY_PC_IPV4>, user "MY-USER", database "MY-DB", SSL off

Can somebody help me? I’m banging my head against the wall as I seem to be doing something very wrong.

I created the clusters normally and they are accepting all incoming connections (no IP restrictions).

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @alramalho

It seems like SSL mode is not enabled.

By default, you are not permitted to transmit data unencrypted (meaning SSL is required). Can you attempt the connection again with SSL enabled? You can download the CA Certificate from your database connection details to use verify-ca or verify-full SSL modes.

https://docs.digitalocean.com/products/databases/postgresql/how-to/secure/#increase-the-ssl-mode-verification-level

Regards, Priyanka