Question

MySQL Workbench Connection

  • Posted October 15, 2014

I have already come very far from bluehost to digitalocean configuration, but im struggling with mysql workbench login from my pc. In bluehost i could just whitelist my current home IP and then login with mysql workbench, when i set .cnf to: 0.0.0.0 . and try to connect in mysql workbench over standard (tcp/ip) im presented with password promt (in sudo password works) which i enter and then get error: Access denied for user ‘root’@‘59-44.77-71.cust.xxxx.com’(using password:YES). any idea what im doing wrong?

Subscribe
Share

yes, thats why on Putty and sudo mysql it’s working. but not in workbench…:(

Just to be clear, it should be the password MySql root user, not the login password. Is that what you’re using?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Have you checked your bind setting in the my.cnf, it should be binded to the outbound IP address of your droplet.

seems to work now, i had to use something like that too: GRANT ALL PRIVILEGES ON . TO ‘jan’@‘83.76.14.59’

guess need to read into user management of mysql more. an handy manual would be helpful for that, there are some but not as easy as for others subjects.