Question

Need some help with a basic email server setup

  • Posted June 21, 2014

Running Debian Wheezy 64bit on a 500MB RAM Droplet.

All the accounts redirect to root and root redirects to an external email via /etc/aliases - this is all good and working.

I now need to additional email accounts: daily and mike. I’ve created the users but am facing the problem that the emails for root were located in /var/mail (no longer apparently, the root file in there now has 0 as size) and the new accounts have their email inside /home/mike but both daily and mike have this fodler structure: <pre> root@server:/home/daily# ls -al total 32 drwxr-xr-x 4 daily daily 4096 Jun 13 14:31 . drwxr-xr-x 4 root root 4096 Jun 12 06:45 … drwx------ 2 daily daily 4096 Jun 13 14:29 Mail drwx------ 5 daily daily 4096 Jun 13 14:31 Maildir </pre> Mail is empty though. <pre> root@server:/home/daily# ls -al Maildir/ total 20 drwx------ 5 daily daily 4096 Jun 13 14:31 . drwxr-xr-x 4 daily daily 4096 Jun 13 14:31 … drwx------ 2 daily daily 4096 Jun 13 14:31 cur drwx------ 2 daily daily 4096 Jun 18 03:33 new drwx------ 2 daily daily 4096 Jun 18 03:33 tmp </pre> So it looks like mails are getting delivered into Maildir/ but checking from terminal: <pre> root@server:/home/daily# su mike mike@server:/home/daily$ mail No mail for mike </pre> Any ideas on how to fix this? I’m running postfix and dovecot. No virtual users, only these two I’ve mentioned are needed…

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

We have a tutorial on setting up postfix and dovecot that should point you in the right direction. Check it out:

https://www.digitalocean.com/community/tutorials/how-to-set-up-a-postfix-e-mail-server-with-dovecot

If you’re still having issues, could you post some information about you postfix configuration? Run:

<pre>postconf -n</pre>