Question

Need to increase file upload allowance and confirm the root folder location for updating WP theme

I have 1 droplet with 5 working sites in it. Trying to update the theme for one of them.

I’m trying to upload a theme in .zip format but get the error message “413 Request Entity Too Large” (via traditional Wordpress theme back end)

I am also connecting to my droplet using Filezilla, I’m trying to navigate to main directory.

It seems like /var/www/html is supposed to be the main directory, but I there is nothing there, only an index.html and an info.php.

If I got to /root/restore/httpdocs I see all of the sites in my droplet on it. I uploaded a theme to that location using FTP, but it doesn’t show on WP backend. So my question is, what is the right directory?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

The default on Ubuntu is /var/www/html for Apache and Nginx but with a multi-site configuration it’s likely that someone changed the defaults. You can find out the root location for each site by looking at the configuration files in /etc/apache2/sites-enabled or /etc/nginx/sites-enabled depending on which web browser you are using.

You can resolve the 413 error you are seeing by adjusting the settings in your php.ini. This will be located in:

/etc/php/fpm/

or

/etc/php7-0/

and the items you’ll want to change are:

max_post_size
upload_max_size