Question

need to sent mail from server very slowly .

I have installed postfix server in ubuntu , thats is working fine , but i need to sent mail from server very slowly ,

Because some time we will sent bulk mails , so all mails send together so receiver will consider as a spam, So i need to send mail very slowly , one minute maximum sent 33 mails , same time all mails should be in queue .

Can you advice me how to do that


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks for support , am using default Post-fix configuration only extra i have added below value , but i don’t know below settings will meet my requirement .

smtp_destination_concurrency_limit = 1 smtp_destination_rate_delay = 3s

Regards, Shufil

@shufilk

If you happen to be sending e-mail through an application, most have built-in functionality that allows you to break up bulk e-mail and only send every X seconds or Y minutes, or should. I know way back in 2005, forum software (vBulletin) was using something similar, so modern applications should have something similar to prevent all e-mail being sent at the same time.

You can modify Postfix configuration as well, as noted by @hansen , though I would also look to your application to see if there are configurable options there as well.

Try adding this to your main.cf

smtp_destination_concurrency_limit = 1
smtp_destination_rate_delay = 3s