Question

Netbox Webpage not loading

Just setup netbox with nginx. Had a little trouble with the openssl cert but resloved that. However my url is not opening. I’m not having any service errors for netbox-rq or for nginx When i ran the “sudo systemctl enable netbox netbox-rq” that test was fine and i could get to the url.

I’m not sure how to test or check from here, I’m not a strong linux user yet, please help?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Okay it’s a certificate issue. I can open and bypass the cert in firefox. Need to figure out how to fix that.

We only use ipv4 on prem so not sure if this could be the issue? But still not resolving

so i have a look around and tried this in my nginx .conf listen [::]:80; listen 80;

Because netstat -tulpen | grep nginx

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 0 39134 3084/nginx: master
tcp6 0 0 :::80 :::* LISTEN 0 39135 3084/nginx: master
tcp6 0 0 :::443 :::* LISTEN 0 39133 3084/nginx: master