Question

Network not starting after reboot

restarted by droplet last night using CLI. Didn’t pay much attention, because i’ve never had too.

Today realized I hadn’t received any emails, which is that server. Couldn’t load zpanel via web browser. Finally got in it through console. Restarted again and saw an error on startup saying NetworkManager-wait-online had failed.

Powered off via shutdown command. Then started again. same failure.

ifconfig eth0 shows NO ip.

through console, journalctl -xe is almost useless because it cuts off text.

stopped network via init.d, flushed dev via ip command, started networking again. nothing.

EXCEPT NetworkManager-wait-online is now running, before the flush systemctl status said it wasn’t… but networking still won’t start.

also: my registered email address for DO is on that server. So i won’t get notifications of replies until i refresh this page. I’ll try to keep watching.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This solution worked for me as well. Updating CentOS 7 to the latest broke networking completely in my droplet, but in my case, only the gateway parameter was missing.

With the email going out telling everyone to update their installs, there could be a lot of confused newbies out there (like myself!), so here’s exactly what worked for me:

  • Check /etc/sysconfig/network-scripts/ifcfg-eth0
  • Make sure everything is there (IP, netmask, gateway)
  • Restart the network service

so after putting all the IP information back in, I can’t reboot, otherwise I have to do enter it all in again.

I found this fix but it looks like we have to wait until it actually gets implemented upstream… @Surety01 I think this comment may be a temporary fix.

EDIT: I just applied the cloud.cfg edit/fix to my CentOS 7.4 droplet, and came back to confirm that it works, as I applied it and rebooted to test as well - so far so good.

Doing a little research into this issue, it seems that CentOS 7 Droplets that are upgraded to CentOS 7.4 and cloud-init 0.7.9 can experience an issue where the Gateway is not properly set by cloud-init on boot. This also seems to be solved in our newer CentOS 7.4 Droplet image.

A bug report with information related to this issue with cloud-init can be found here:

https://bugzilla.redhat.com/show_bug.cgi?id=1497358