Never seen this error before while uploading a file: [proxy_fcgi:error]

January 25, 2017 209 views
PHP Ubuntu 16.04

I have a simple php upload script, and fixed all the permissions errors. But now I'm getting the error before, and I gotta say. It's new to me.

Here is my error log line

[Wed Jan 25 05:19:29.686826 2017] [proxy_fcgi:error] [pid 13006:tid 140047718270720] [client 108.31.95.23:54646] AH01071: Got error 'PHP message: /app/assets/stills/dpstRh.jpg\n', referer: http://gifturtle.com/upload

2 Answers

@amir.meshkin

From what I'm seeing on similar errors, would you by chance be running Apache configured to run PHP-FPM? If so, would you be able to post your VirtualHost server block for the site in question?

If you're not running Apache and are instead running NGINX, please post the NGINX server block as well as your fastcgi_params (should be in /etc/nginx unless you're using a custom config).

I used basically the default vhosts file and just copied it. Is this what you want to see?

<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request's Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
#ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html/gifturtle.com

ServerName gifturtle.com
ServerAlias www.gifturtle.com

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

</VirtualHost>

Have another answer? Share your knowledge.