Question

New customer, multiple questions (No search in forum, Terminal characters, PPA)

  • Posted May 27, 2013
  • There is no search in the forum?

  • When I log in to the box with ssh (osx iTerm2) I get funky characters (that I can’t undo) when I trying to navigate/edit using vi. The arrow characters don’t work. I can use the vi friendly hjkl and that is fine but still it is ‘different’ than other servers I’m used to - is there a terminal setting for this?

  • I’d like to use ppa: repos. http://blog.brightbox.co.uk/posts/nginx-passenger-3-ubuntu-packages

I’ve installed the python package that I thought enabled this:

sudo apt-get install python-software-properties … success

sudo apt-add-repository ppa:brightbox/ruby-ng sudo: apt-add-repository: command not found

I installed apt-file to search for the command - it is there hmmm, bummer :( what did I miss …

apt-file search add-apt-repository software-properties-common: /usr/bin/add-apt-repository software-properties-common: /usr/share/man/man1/add-apt-repository.1.gz

Thank you :P

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@paul Glad to hear that :) Let me know how it goes.

Vim-nox - did the trick - I’m a happy vm’r again. :P <br> <br>The software-properties-common package installed - but I have not gotten a chance to try it out and I bet it works :) <br> <br>Thank you Kamal! <br> <br>Paul <br> <br>

  • There is no search in the forum? <br> <br>There isn’t a search functionality at the moment. <br> <br>> - When I log in to the box with ssh (osx iTerm2) I get funky characters (that I can’t undo) when I trying to navigate/edit using vi. The arrow characters don’t work. I can use the vi friendly hjkl and that is fine but still it is ‘different’ than other servers I’m used to - is there a terminal setting for this? <br> <br>I suggest installing the vim-nox package --it should fix that. <br> <br>> - I’d like to use ppa: repos. http://blog.brightbox.co.uk/posts/nginx-passenger-3-ubuntu-packages <br> <br>Install the software-properties-common package.