Question

new droplet on private network cannot access other droplets

I had 3 droplets running with a private network setup. Recently I had to destroy and recreate one of the droplets. The new droplet cannot longer talk on the private network. Its eth1 interface seems completely shut off from the rest of the world.

To recreate the droplet I used the same command I had previously used:

docker-machine create --driver digitalocean --digitalocean-access-token $DIGITAL_OCEAN_TOKEN \
--digitalocean-image ubuntu-18-04-x64 --digitalocean-size s-4vcpu-8gb --digitalocean-region nyc3 \
--digitalocean-private-networking --digitalocean-monitoring \
--digitalocean-ssh-key-fingerprint MY_FINGERPRINT MY_HOST

I specifically checked the file /etc/netplan/50-cloud-init.yaml and it looked correct and I could see eth1 listed in there.

Any steps you can provide me on debugging this issue?

Thanks!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Great and thorough answer. Thank you.

Hello!

As a quick bit of caution, private network settings will only work across Droplets in the same datacenter on the same account. With that in mind, let’s dig in a bit more!

After taking a look over the 50-cloud-init.yaml file, one of the first things that I’d recommend checking is whether you see any issues when applying those same settings with the following Netplan commands:

sudo netplan generate
sudo netplan apply

If all is well, you can take a look at the active interfaces with ifconfig and make sure that eth1 is showing as UP and broadcasting the proper IP address and that the route is registering properly with your Droplet via route. There can also be a blocker configured in your firewall so I’d certainly recommend ensuring that only proper firewall rules are currently enabled:

sudo iptables -nvL --line-numbers

Should there be any further issues after verifying these things, it may be best to reach out to our Support team to get some specific details regarding your Droplet. Let me know if you have any other questions!