Question

New error this week: certbot-dns-digitalocean says: (acme 0.31.0 (/usr/lib/python3/dist-packages), Requirement.parse('acme>=0.40.0'))

Ubuntu 18.04.03, just spun up…

Using apt repos and packages:

  • ppa:certbot/certbot
  • python-certbot-apache python-pip python3-pip
  • pip install certbot-dns-digitalocean
  • pip3 install certbot-dns-digitalocean
  • Tried pip and pip3 each/both every way

Then, each of these…

certbot certonly --dns-digitalocean --dns-digitalocean-credentials /path/to/digitalocean/apikey...
certbot --apache certonly...
certbot --manual certonly --preferred-challenges=dns...

Returns the error:

pkg_resources.VersionConflict: (acme 0.31.0 (/usr/lib/python3/dist-packages), Requirement.parse('acme>=0.40.0'))

Is the certbot-dns-digitalocean pip package just out of date? I can’t find anyone else asking.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It seems to work for me after installing an earlier version of the pip package managing the dns-challenge.

You are not alone, I faced the same error today (not on digital ocean) on a clean server.

root@qa4k:/etc/sudoers.d# certbot --version
An unexpected error occurred:
pkg_resources.VersionConflict: (acme 0.31.0 (/usr/lib/python3/dist-packages), Requirement.parse('acme>=0.40.0'))
Please see the logfile '/tmp/tmpbk7msfxr/log' for more details.
root@qa4k:/etc/sudoers.d# cat /tmp/tmpbk7msfxr/log
2020-01-25 05:39:41,685:DEBUG:certbot._internal.log:Exiting abnormally:
Traceback (most recent call last):
  File "/usr/local/bin/certbot", line 8, in <module>
    sys.exit(main())
  File "/usr/local/lib/python3.6/dist-packages/certbot/main.py", line 15, in main
    return internal_main.main(cli_args)
  File "/usr/local/lib/python3.6/dist-packages/certbot/_internal/main.py", line 1317, in main
    plugins = plugins_disco.PluginsRegistry.find_all()
  File "/usr/local/lib/python3.6/dist-packages/certbot/_internal/plugins/disco.py", line 206, in find_all
    plugin_ep = PluginEntryPoint(entry_point)
  File "/usr/local/lib/python3.6/dist-packages/certbot/_internal/plugins/disco.py", line 48, in __init__
    self.plugin_cls = entry_point.load()
  File "/usr/local/lib/python3.6/dist-packages/pkg_resources/__init__.py", line 2443, in load
    self.require(*args, **kwargs)
  File "/usr/local/lib/python3.6/dist-packages/pkg_resources/__init__.py", line 2466, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/usr/local/lib/python3.6/dist-packages/pkg_resources/__init__.py", line 792, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.VersionConflict: (acme 0.31.0 (/usr/lib/python3/dist-packages), Requirement.parse('acme>=0.40.0'))
2020-01-25 05:39:41,685:ERROR:certbot._internal.log:An unexpected error occurred: