Question

New Ghost blog not updating. Help?

Hi,

I used the one click app install to set up a Ghost blog. I have set up sftp and added a new theme to the blog. I have also made some changes to the hbs files in the theme and am attempting to upload them via sftp (the same way I uploaded the theme).

It’s weird - the FTP app on my Mac (Transmit) confirms that the file was transferred, but no matter how many times I refresh the page, restart Ghost, sign out and sign in, wait an hour - it doesn’t update.

Any tips on what i’m doing wrong and how I can get this site to update?

Thanks.

Subscribe
Share

I may have ran into the same issue myself a few months ago. It turns out that the ghost blog has to be restarted to detect new themes.

According to the documentation at https://www.digitalocean.com/community/tutorials/how-to-use-the-digitalocean-ghost-application, you can restart the glost blog by using (as root, most likely)

service ghost restart

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This question was answered by @SphericalCow:

I may have ran into the same issue myself a few months ago. It turns out that the ghost blog has to be restarted to detect new themes.

According to the documentation at https://www.digitalocean.com/community/tutorials/how-to-use-the-digitalocean-ghost-application, you can restart the glost blog by using (as root, most likely)

service ghost restart

View the original comment