Question

New server getting random 404 errors!

  • Posted on July 11, 2014
  • baines86Asked by baines86

Ok guys, I have unbuntu 14.04 and LEMP installed I’ve been running the server for about a day and a half and many of my customers are complaining of 404 errors at random. The pages load for some people but not for others! (The files do EXIST!!) I don’t know what’s happening. The error log was 1.2 GB so I know something is happening, but I couldn’t read it because it was so large. so i deleted it and I’m going to look at it in a few hours. Hoping that helps or i can get a good answer from yall!! all the files are PHP files. I just had all these files on another server a few days ago and didn’t experience any problems!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I set error logging to critical errors only (so right now the log is empty), as i think it was a major problem! some pages were loading 120+ useless errors per page. I fixed a bunch of them, but there still is quite a few more. I also doubled the memory limit, it seems to be running fine at the moment. I’ll monitor it for the next few hours!

On what package does your server runs and how many visotors do you have? Maybe if you increase the PHP memory the problem will be solved.