Question

New wordpress image faulty? (unable to create folder (WP 18.04))

Posted July 14, 2019 364 views
WordPressDigitalOceanUbuntu 18.04

I would have put this in general but I’ve done nothing to the configuration except follow instruction.

4GB Ram, 80 storage, more than enough power for a wordpress instance, the only adjustments I’ve made is give it a tls cert, and whitelisted my IP in fail2ban config

I’m unsure how to troubleshoot this, the only difference I can see is that the installer has changed, fail2bad is there (maybe some other things) but, I can’t install plugins, or I can’t create the folders to do so, I’ve checked and checked and destroyed and rebuilt from vanilla builds, there is an issue with this one

permissions are fine. I tried default, I tried to chown them to what they already are, I’ve tried adjusting

has anyone else seen this ?

apologies if I’m not preparing this question very well

to be clear, no plugins can be installed. the permissions haven’t been touched, (well they have to test if it’s a permission issue, on images now destroyed)

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @Carroll,

It looks like we possibly had an issue with our Wordpress 1-Click image, we’ve now deployed a fixed version but this will only be reflected in new Droplets/installations.

Please can you try running chown -Rf www-data.www-data /var/www/html as root for me and let me know if that fixes your install?

Hope that helps!
- Matt.

Submit an Answer