Question

new wordpress install issue ERR_CONNECTION_REFUSED

I followed the tutorial here https://www.youtube.com/watch?v=gZMYG3e7IEc but no matter what I try I am unable to login to the backend or access any page

I am not the only one that cannot access it and I’ve tried all solutions by Google be it flush DNS, turn off firewall, and so on. This has gotten really frustrating when all I want to do is set up a new WordPress site install.

Here is the error log :

[Sun Jul 12 20:42:51.837091 2020] [mpm_prefork:notice] [pid 1017] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Sun Jul 12 20:42:51.837203 2020] [core:notice] [pid 1017] AH00094: Command line: '/usr/sbin/apache2'
[Sun Jul 12 20:55:09.318531 2020] [mpm_prefork:notice] [pid 1017] AH00169: caught SIGTERM, shutting down
[Sun Jul 12 20:55:09.451849 2020] [mpm_prefork:notice] [pid 2103] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Sun Jul 12 20:55:09.451934 2020] [core:notice] [pid 2103] AH00094: Command line: '/usr/sbin/apache2'
[Sun Jul 12 20:57:26.843173 2020] [mpm_prefork:notice] [pid 2103] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Sun Jul 12 20:57:26.907357 2020] [mpm_prefork:notice] [pid 2103] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Sun Jul 12 20:57:26.907374 2020] [core:notice] [pid 2103] AH00094: Command line: '/usr/sbin/apache2'
[Sun Jul 12 20:57:33.445518 2020] [mpm_prefork:notice] [pid 2103] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
[Sun Jul 12 20:57:33.541964 2020] [mpm_prefork:notice] [pid 2103] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Sun Jul 12 20:57:33.541980 2020] [core:notice] [pid 2103] AH00094: Command line: '/usr/sbin/apache2'
[Mon Jul 13 04:59:36.905662 2020] [mpm_prefork:notice] [pid 2103] AH00169: caught SIGTERM, shutting down
[Mon Jul 13 04:59:37.062952 2020] [mpm_prefork:notice] [pid 6840] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Mon Jul 13 04:59:37.063037 2020] [core:notice] [pid 6840] AH00094: Command line: '/usr/sbin/apache2'

Submit an answer


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
August 6, 2023

Hi there,

The error log you posted doesn’t seem to contain any specific error messages related to the problem you’re experiencing with your site, but one warning message does stand out:

AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message

This message indicates that Apache is unable to determine the FQDN of your server. While this alone wouldn’t prevent your site from loading, it might point to an issue in your configuration.

Here are some steps you can take to further troubleshoot this issue:

  1. Set the ServerName Directive:

    • Open your Apache configuration file, usually located at /etc/apache2/apache2.conf.
    • Add a line at the end of the file with your domain name: ServerName zway.com.
    • Restart Apache: sudo systemctl restart apache2.
  2. Check Your Virtual Host Configuration:

    • Ensure that the configuration file for your site (usually located in /etc/apache2/sites-available/) is set up correctly.
    • It should include the proper ServerName and DocumentRoot directives.
    • If you’re using HTTPS, make sure your SSL certificates are configured correctly.
  3. Check Your DNS Settings:

    • Make sure your domain name is correctly pointing to your server’s IP address.
    • You can use tools like dig or nslookup to verify the DNS settings.
  4. Examine Apache’s Error Log:

    • You might find more detailed error messages in Apache’s error log, typically located at /var/log/apache2/error.log.
  5. Verify Firewall and Network Settings:

    • If you’ve made any changes to your firewall or network configuration, make sure that ports 80 (HTTP) and 443 (HTTPS) are open and that nothing is blocking connections to your site.
  6. Try Loading the Site from a Different Device/Network:

    • Sometimes, local caching or network issues can prevent a site from loading correctly. Try accessing the site from a different device or network to see if the problem persists.
  7. Ensure Necessary Modules are Enabled:

    • If you are using SSL, make sure that the necessary modules are enabled by running the following commands:
sudo a2enmod ssl
sudo a2enmod headers
sudo systemctl restart apache2

If you continue to encounter problems, I could suggest using the 1-Click WordPress installation here:

https://marketplace.digitalocean.com/apps/wordpress

Best,

Bobby

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel