Question

NextCloud Version: 16.0.7.1 - Allowed Memory_Limit failure

Posted January 28, 2020 1.9k views
PHP

Hello,
using NextCloud Snap Version 16.0.7.1 and got failure that Memory Limit is under 512 MB.

Where can i change it?

i tried to change in following directory:

sudo vi /etc/php/7.2/cli/php.ini
try to change Limit from = -1 to 512

But nothing happened after Reboot

Thanks a lot

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

I resolved my issue with the PHP memory limit with my snap installation by using the this command:

$ sudo snap set nextcloud php.memory-limit=512M

More information can be found here: https://github.com/nextcloud/nextcloud-snap 222

You can restart the snap by using this command: sudo systemctl restart snap.nextcloud.apache

Hope this helps

Hello, all

For NextCloud installed via snap you can refer to:

https://github.com/nextcloud/nextcloud-snap

You can also create a PHP info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of memory_limit you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

memory_limit = 256M

You also need to restart your web server in order for the changes to take effect.

Hope that this helps!
Regards,
Alex