Question

nginx 403 forbidden ...

  • Posted January 11, 2014

I used this article https://www.digitalocean.com/community/articles/how-to-set-up-nginx-virtual-hosts-server-blocks-on-ubuntu-12-04-lts--3 to setup virtual hosts on nginx but I’m getting a 403 forbidden error.

The article tells us to do this to set permissions

You can replace the "www-data" below with the appropriate username. sudo chown -R www-data:www-data /var/www/example.com/public_html Additionally, it is important to make sure that everyone is able to read our new files. sudo chmod 755 /var/www

I therefore did this with my username

sudo chown -R username:username /var/www/example.com/public_html

but I’m still getting the 403 forbidden errror. Do you know anything I can try?

Subscribe
Share

Hi what is this I have no idea for its


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@doper408: Simply replace index.html with your own index.html that you want to use and you should be fine. If it’s a PHP app, replace index.html with your own index.php file and make sure the <code>index</code> directive is set to <code>index.php index.html</code> (e.g.: <code>index index.php index.html;</code>) in your nginx’s virtual host config.

Do you have a file called index.html in /var/www/mydomain.com/public_html?

Do you have a file called index.html in /var/www/mydomain.com/public_html?

Thanks, this was the output of ps -ef | grep nginx <br> <br>root 14130 1 0 16:06 ? 00:00:00 nginx: master process /usr/sbin/nginx <br>www-data 14132 14130 0 16:06 ? 00:00:00 nginx: worker process <br>www-data 14133 14130 0 16:06 ? 00:00:00 nginx: worker process <br>www-data 14134 14130 0 16:06 ? 00:00:00 nginx: worker process <br>www-data 14135 14130 0 16:06 ? 00:00:00 nginx: worker process <br>michael 14900 14326 0 17:35 pts/2 00:00:00 grep --color=auto nginx <br> <br> <br>Therefore, was I correct to do this? <br>sudo chown -R username:username /var/www/example.com/public_html <br> <br>This is what the tutorial says this <br> <br>You can replace the "www-data" below with the appropriate username. <br>sudo chown -R www-data:www-data /var/www/example.com/public_html <br> <br>right now I'm signed in as michael` can I fix this problem

Using command in sudo chmod 777 -R folderpath

If your file structure is outside the default location, you might need to add the “username” to the “www-data” group. Replace username with the appropriate one for your environment.

usermod -aG username www-data

Hello I have resized a droplets and it gives me the following error: 403 Forbidden nginx / 1.14.0 (Ubuntu)

is on Ubuntu server 18 I have performed the procedures in this post and the problem persists. Can you help me with this?

Everything could be okay with your permissions. In my case, I got the same just because of wrong config. For example no or wrong php settings, no index.php as a root file or even wrong root folder.

Also your problem could be caused “sudo chmod 755 /var/www”, because it doesn’t contain -R flag. That’s important too.

I Need Help To Download A MemoryHackers Download Sector Because I Can Not Download Because A 403 Forbidden nginx

@Kamal Nasser , thanks a lot that work great, but only for the main page when a visit a page for example, domain.com/example I get “500 Internal Server Error” any suggestion to fix this. thanks in advance