Question

Nginx Nextcloud Postgresql and php-fpm on OpenSUSE 15.2

Posted June 12, 2021 247 views
NginxPHP

I installed Nextcloud 21 with NGINX, postgresql 12 and PHP_FPM. All services were installed and running and configured. But, when try to access the nextcloud site to finish web service and run, its shows me:
404 Not Found - nginx/1.16.1

check the error.log:
tail -f /var/log/nginx/error.log

2021/06/12 15:49:35 [error] 1722#1722: 2 open() “/usr//html/index.php” failed (2: No such file or directory), client: *IP**, server: myservernextcloud, request: “GET /index.php HTTP/1.1”, host: “myservernextcloud”

my /etc/nginx/vhosts/nextclou.conf

upstream php-handler {
    server 127.0.0.1:9000;
    #server unix:/var/run/php/php7.4-fpm.sock;
}

server {
    server_name my_server;

    listen [::]:443 ssl ipv6only=on; # managed by Certbot
    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/my_server/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/my_server /privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}

server {
    if ($host = my_server) {
        return 301 https://$host$request_uri;
    } # managed by Certbot

    listen 80;
    listen [::]:80;
    server_name my_server;
    return 404; # managed by Certbot


   # ssl_protocols TLSv1.2 TLSv1.3;
   # ssl_ciphers HIGH:!MEDIUM:!LOW:!aNULL:!NULL:!SHA;
   # ssl_prefer_server_ciphers on;
   # ssl_session_cache shared:SSL:10m;

    # HSTS settings
    # WARNING: Only add the preload option once you read about
    # the consequences in https://hstspreload.org/. This option
    # will add the domain to a hardcoded list that is shipped
    # in all major browsers and getting removed from this list
    # could take several months.
   add_header Strict-Transport-Security  "max-age=31536000; includeSubDomains"   always;

    # set max upload size
    client_max_body_size 512M;
    fastcgi_buffers 64 4K;

    # Enable gzip but do not remove ETag headers
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/vnd.ms-fontobject application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/bmp image/svg+xml image/x-icon text/cache-manifest text/css text/plain text/vcard text/vnd.rim.location.xloc text/vtt text/x-component text/x-cross-domain-policy;

    # Pagespeed is not supported by Nextcloud, so if your server is built
    # with the `ngx_pagespeed` module, uncomment this line to disable it.
    #pagespeed off;

    # HTTP response headers borrowed from Nextcloud `.htaccess`
    add_header Referrer-Policy                      "no-referrer"           always;
    add_header X-Content-Type-Options               "nosniff"               always;
    add_header X-Download-Options                   "noopen"                always;
    add_header X-Frame-Options                      "SAMEORIGIN"            always;
    add_header X-Permitted-Cross-Domain-Policies    "none"                  always;
    add_header X-Robots-Tag                         "none"                  always;
    add_header X-XSS-Protection                     "1; mode=block"         always;

    # Opt out of Google Chrome tracking everything you do.
    # Note: if you’re reading this, stop using Google Chrome.
    # It is ridiculous for web servers to essentially have to ask
    # “please do not violate the privacy of the people who are viewing
    # this site” with every request.
    # For more info, see: https://plausible.io/blog/google-floc
    add_header Permissions-Policy                   "interest-cohort=()"    always;

    # Remove X-Powered-By, which is an information leak
    fastcgi_hide_header X-Powered-By;

    # Path to the root of your installation
    root /srv/www/htdocs/nextcloud;


    # Specify how to handle directories -- specifying `/index.php$request_uri`
    # here as the fallback means that Nginx always exhibits the desired behaviour
    # when a client requests a path that corresponds to a directory that exists
    # on the server. In particular, if that directory contains an index.php file,
    # that file is correctly served; if it doesn't, then the request is passed to
    # the front-end controller. This consistent behaviour means that we don't need
    # to specify custom rules for certain paths (e.g. images and other assets,
    # `/updater`, `/ocm-provider`, `/ocs-provider`), and thus
    # `try_files $uri $uri/ /index.php$request_uri`
    # always provides the desired behaviour.
    index index.php index.html /index.php$request_uri;


    # Rule borrowed from `.htaccess` to handle Microsoft DAV clients
    location = / {
        if ( $http_user_agent ~ ^DavClnt ) {
            return 302 /remote.php/webdav/$is_args$args;
        }
    }

    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }

    # Make a regex exception for `/.well-known` so that clients can still
    # access it despite the existence of the regex rule
    # `location ~ /(\.|autotest|...)` which would otherwise handle requests
    # for `/.well-known`.
    location ^~ /.well-known {
        # The following 6 rules are borrowed from `.htaccess`

        location = /.well-known/carddav     { return 301 /remote.php/dav/; }
        location = /.well-known/caldav      { return 301 /remote.php/dav/; }
        # Anything else is dynamically handled by Nextcloud
        location ^~ /.well-known            { return 301 /index.php$uri; }

        try_files $uri $uri/ =404;
    }

    # Rules borrowed from `.htaccess` to hide certain paths from clients
    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)(?:$|/)  { return 404; }
    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console)              { return 404; }

    # Ensure this block, which passes PHP files to the PHP process, is above the blocks
    # which handle static assets (as seen below). If this block is not declared first,
    # then Nginx will encounter an infinite rewriting loop when it prepends `/index.php`
    # to the URI, resulting in a HTTP 500 error response.


     location ~ \.php$ {
                # 404
                try_files                     $fastcgi_script_name =404;

                # default fastcgi_params
                include                       /etc/nginx/fastcgi_params;

                # fastcgi settings
                fastcgi_pass                  127.0.0.1:9000;
                fastcgi_index                 index.php;
                fastcgi_buffers               8 16k;
                fastcgi_buffer_size           32k;

                # fastcgi params
                fastcgi_param DOCUMENT_ROOT   $realpath_root;
                fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name;
        }     


    location ~ \.(?:css|js|svg|gif)$ {
        try_files $uri /index.php$request_uri;
        expires 6M;         # Cache-Control policy borrowed from `.htaccess`
        access_log off;     # Optional: Don't log access to assets
    }

    location ~ \.woff2?$ {
        try_files $uri /index.php$request_uri;
        expires 7d;         # Cache-Control policy borrowed from `.htaccess`
        access_log off;     # Optional: Don't log access to assets
    }

    location /nextcloud {
        try_files $uri $uri/ /nextcloud/index.php$request_uri;
    } 

   # location / {
   #    # try_files $uri $uri/ /index.php$request_uri;
   #     try_files $uri $uri/ /index.php?q=$uri&$args;

   # }
}

No errors on postgresql
No errors on php-fpm
no errors on nginx

How can I fix this?
Please, somebody can help me?

Thank you!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @doguibnu,

Looking at the error from your error_log:

“/usr//html/index.php” failed (2: No such file or directory)

See the folder it’s trying to reach. Your root folder is:

    # Path to the root of your installation
    root /srv/www/htdocs/nextcloud;

It seems to me like something wasn’t configured properly. One of the things, I can think of is a missing symlink:

sudo ln -s /etc/nginx/sites-available/example.com /etc/nginx/sites-enabled/

See if you have a symlink between your configuration file for the sites-available and sites-enabled folder.

Additionally, make sure you’ve restarted Nginx after all changes.

  • Hello!

    The OpenSUSE distro does not has:
    /etc/nginx/sites-available/example.com /etc/nginx/sites-enabled/

    The conf block nginx files stay on: /etc/nginx/vhosts.d/some_name.conf

    But, Thank you attention and help!

    • Hi @doguibnu,

      Point taken! Anyway, did you manage to find the source of the issue? If yes, can you share it with us

      • Hello @KFSys

        I forget to tell you that Nextcloud its on virtualbox. I tried configure Nextcloud about 3 Distros flavors _ OpenSUSE, Ubuntu and Debian. The server is behind pfsense firewall. So there is a NAT for server (public IP to 10.x.x.x) HTTP and HTTPS ports are open.

        Using postgresql or MariaDB and php-fpm more nginx I be able do the first connection (let’s encrypt working and configured). But, at finish and last part to “install and configure” nextcloud, after some time, The web navigator simple stop, and shows - INTERNAL SERVER ERROR.

        Reading other log, I understand that no possible do the connection with nextcloud server for some reason.

        I think this can be a virtualbox network configuration, butttt: Where the place?

        Virtualbox Nextcloud is Bridged Mode connection configuration and server with static IP (10.x.x.x)

        So.... I do not know what to do.....still

        Thank you so much