nginx not coming up with ip but works fine with localhost

As I was following the tutorial :

I have succesfully configured the nignx but I am not able to launch nginx server with my public ip but this works fine with local host. Can some one please help me this?

The command: curl -v doesn’t return the public ip address as well.

Regards Aashay


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This is probably an error with port 80. Check your firewall and check if port 80 is allowed to establish connections.

Check firewall status:

sudo ufw status

Allow Nginx Full in the firewall:

sudo ufw allow "Nginx full"

Activate your system firewall:

sudo ufw enable

Read more about firewall here - How To Set Up a Firewall with UFW on Ubuntu 18.04