Nginx page displaying instead of home page

May 27, 2015 7.2k views
Nginx Getting Started LEMP DigitalOcean Ubuntu

Whenever I enter the IP address of my site, I get this page:

Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to
Commercial support is available at

Thank you for using nginx.

I have searched for answers, but have not found anything that works for me. I am running Ubuntu LEMP on 14.04, and used the one-click installation. The only thing I have done so far is to add a folder in the main directory, and call it "public." This is where I will put my folders/pages etc.

Because of this change, I would like to set up the "public" folder as the root folder of my site, so that it will look there for an "index.***" page when displaying to a user. I changed the "etc/nginx/available-sites/default.conf" file to hopefully accomodate this:

server {
    listen 80 default_server;
    listen [::]:80 default_server ipv6only=on;

    root /public/;
    index index.php index.html index.htm;

    # Make site accessible from http://localhost/
    server_name localhost;

    location / {
        # First attempt to serve request as file, then
        # as directory, then fall back to displaying a 404.
        try_files $uri $uri/ =404;
        # Uncomment to enable naxsi on this location
        # include /etc/nginx/naxsi.rules

    error_page 404 /404.html;
    error_page 500 502 503 504 /50x.html;
    location = /50x.html {
        root /usr/share/nginx/html;

    location ~ \.php$ {
        try_files $uri =404;
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;



However, I am still only getting the Nginx welcome page when I access my site by IP, and it is getting annoying. How can I show the home page?

Let me know if I need to add anything else. Thanks!

  • have you check error log? perhaps on /var/log/nginx/error.log. You might get a clue from there

  • @sumodirjo I think what happened is that I didn't wait quite long enough for the DNS changes to take effect, as it is now working rather well when I type in the URL (before it was displaying the Namecheap page). However, typing in the IP still results in the nginx page. I'm going to give it another day and see what happens.

  • still confused???? anybody have any answers

  • This happened to me when my http server was listening on port 80. Once I switched to another port such as 8080 or 3000, it went away. Hope that helps..

1 Answer
Have another answer? Share your knowledge.