Question

nginx / php-fpm rewriting for laravel

Hi all,

I am new to configuring nginx and have been following many tutorials but to no avail in trying to get a subdomain routed correctly.

quick sidenotes, my domain is hosted elsewhere and for now I have beta.domain pointing to DO - until I can test site works then I will migrate. Also, my LEMP installation is the default just with my custom site.

my sites-available/example.com file reads as follows (note it’s not actually called example.com i’m just substituting that for question purposes).

server {
        listen 80 default_server;
        listen [::]:80 default_server ipv6only=on;

        root /usr/share/nginx/example.com/public;
        index index.php;

        server_name example.com;

        try_files $uri $uri/ @rewrite;

        location @rewrite {
                rewrite ^/(.*)$ /index.php/$1;
        }

        location ~ [^/]\.php(/|$) {
                try_files $uri $uri/ @rewrite;
                fastcgi_split_path_info    ^(.+\.php)(/.+)$;
                fastcgi_pass               unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
        }

}

I effectively have this block in my config, one for eaxmple.com and another for beta.example.com.

after a morning trying my laravel is at least working when I do beta.example.com/index.php/page but I would like to turn this into beta.example.com/page.

Thanks in advance for any replies.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

FastCGI’s SCRIPT_FILENAME parameter isn’t set properly – replace

        location ~ [^/]\.php(/|$) {
                try_files $uri $uri/ @rewrite;
                fastcgi_split_path_info    ^(.+\.php)(/.+)$;
                fastcgi_pass               unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
        }

with

location ~ \.php$ {
        try_files $uri =404;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        include fastcgi_params;
}

and restart nginx:

sudo service nginx restart