Question

Nginx Restart Fails and Show Not Running, But Site is Being Served.

I have a droplet that I initially set up host gitlab, just the stock installation. My trying to modify it to support other, very light weight sites. I followed the instructions from the Digital Ocean tutorial.

I followed all the steps and when attempting to restart

root@git ~# service nginx restart
 * Restarting nginx nginx                                                                            [fail] 

I’ve done some extensive searches of the web and got turned on to nginx -t.

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

When I check the nginx status:

service nginx status
nginx is not running

or

/etc/init.d/nginx status
 * nginx is not running

I restarted my droplet and the netstat comes back with nginx listening. But when I run service --status-all the nginx line is :

[ - ]  nginx

What am I missing?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

getting same error… anyone know why?