I have analyzed all previous answers to this question and nothing is helping me. I have a django and nginx installation on a Ubuntu 16.04 droplet.

Here is the snippet from my /etc/nginx/sites-available/ , which also is linked to the /sites-enabled directory

server {
    listen       80;
    server_name   **my.droplet.IP.address**;
    charset      utf-8;

    client_max_body_size       10m;
    client_body_buffer_size    128k;

    # serve static files
    location /static/ {
        alias /home/**app-name**/app/static/;
    }

    location /home/ {
        include proxy_params;
        proxy_pass http://unix:/home/**app-name**/django.sock;
    }
}

If someone could please help me, everything seems to be pointing to the right folder, ironically I am trying to learn django but I can’t even get it installed right on the server!

I will be pending this thread so if any more information is needed please let me know!

1 comment
  • PS: I have deleted the default file and symbolic link, I have tried adding return 404 (it returns a 404 error instead of welcome to nginx LOL)

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello,
After editing the conf file did you restart nginx?

sudo service nginx restart

when you delted the defualt link do you make a new conf file?

  • Hello! I did restart -
    sudo systemctl restart nginx

    Does that do the same as your code?

    I have not made a new conf file - I just deleted default in both folders (the file in available, the symbolic link in sites-enabled)

    If you wouldn’t mind, please be more specific about what conf file, where it is, what it should say or what I should search for in the documentation.

    Thank you for responding!

Submit an Answer