Question

nice permalink does not work

  • Posted March 5, 2014

droplet name: fatih1.kancingdoortrim.com IP Address: 128.199.220.172 Status: Active

Yesterday I moved my wordpress blog from old server to DO … everything seems fine, the wordpress site is up and running well on homepage. But the nice permalink is not working, everytime I click link the result is 404.

I saw the tutorial here: https://www.digitalocean.com/community/articles/how-to-use-the-htaccess-file already did this:

  1. sudo nano /etc/apache2/sites-available/default
  2. AllowOverride All were added

but when:

  1. sudo service apache2 start

the result is:

  • Restarting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using fatih1.kancingdoortrim.com for ServerName … waiting apache2: Could not reliably determine the server’s fully qualified domain name, using fatih1.kancingdoortrim.com for ServerName

and still the nice permalink will not work, even after I ‘flush the rewrite rule’ via wordpress’ admin side.

my site is: kancingdoortrim.com here is the record in ‘Zone File’

$TTL 1800 @ IN SOA NS1.DIGITALOCEAN.COM. hostmaster.kancingdoortrim.com. ( 1393905335 ; last update: 2014-03-04 03:55:35 UTC 3600 ; refresh 900 ; retry 1209600 ; expire 1800 ; ttl ) IN NS NS1.DIGITALOCEAN.COM. NS NS2.DIGITALOCEAN.COM. NS NS3.DIGITALOCEAN.COM. @ IN A 128.199.220.172

Need help…

Thanks

Irawan

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

The nice permalink works fine after I write this command <br>sudo a2enmod rewrite <br> <br>However it still says: “Could not reliably determine the server’s fully qualified domain name, using fatih1.kancingdoortrim.com for ServerName” <br>after I execute this command: <br>sudo service apache2 start <br> <br>what could be wrong, because kancingdoortrim.com is a FQDN <br> <br>need help & thanks <br> <br>Irawan

It’s working fine for me now, can you check again? Make sure you clear your browser’s cache.

just replaced with RewriteRule .* /index.php [L] <br>but the problem still persist… <br> <br>

Try replacing <pre>RewriteRule . /index.php [L] </pre> with <pre>RewriteRule .* /index.php [L] </pre>

Hi Kamal Nasser, <br>Thanks for your reply <br>here is the content of /etc/apache2/sites-available/default <br>******************************************** <br><VirtualHost :80> <br> ServerAdmin webmaster@localhost <br> <br> DocumentRoot /var/www <br> <Directory /> <br> Options FollowSymLinks <br> AllowOverride All <br> </Directory> <br> <Directory /var/www/> <br> Options Indexes FollowSymLinks MultiViews <br> AllowOverride All <br> Order allow,deny <br> allow from all <br> </Directory> <br> <br> ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <br> <Directory “/usr/lib/cgi-bin”> <br> AllowOverride All <br> Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch <br> Order allow,deny <br> Allow from all <br> </Directory> <br> <br> ErrorLog ${APACHE_LOG_DIR}/error.log <br> <br> # Possible values include: debug, info, notice, warn, error, crit, <br> # alert, emerg. <br> LogLevel warn <br> <br> CustomLog ${APACHE_LOG_DIR}/access.log combined <br> <br> Alias /doc/ “/usr/share/doc/” <br> <Directory “/usr/share/doc/”> <br> Options Indexes MultiViews FollowSymLinks <br> AllowOverride All <br> Order deny,allow <br> Deny from all <br> Allow from 127.0.0.0/255.0.0.0 ::1/128 <br> </Directory> <br> <br></VirtualHost> <br> <br>********************************* <br>and below is .htaccess <br> <br>******************************** <br><IfModule mod_rewrite.c> <br>RewriteEngine On <br>RewriteBase / <br>RewriteRule ^index.php$ - [L] <br>RewriteCond %{REQUEST_FILENAME} !-f <br>RewriteCond %{REQUEST_FILENAME} !-d <br>RewriteRule . /index.php [L] <br></IfModule> <br> <br>***********************

Can you pastebin the contents of <code>/etc/apache2/sites-available/default</code> and the .htaccess file?